どうも最近呪われているようで、NASに続いてMacBook Proがお亡くなりになった。
スリープから復帰して使おうとしたら、画面が乱れたかと思うとグレー画面になり、動く気配がないので電源ボタン長押しで落とした後、起動してもAppleマークが消えた後先に進まなくなった。
この後、以下を試してみたが改善せず。
  • command + option + p + r(PRAMリセット?最近のmacの場合はPRAMはないらしいが)
  • shift + control + option(SMCリセット)
  • shift(セーフブート)
    同じ症状が出た後、長時間待つとブルースクリーンに
  • command + r(リカバリ)
  • option(ブート選択)
    選択画面は出るので、リカバリ領域や、外部USB HDD(過去にレスキュー用に作ったもの)を選択してみても起動せず
  • command + s(シングルユーザ)
    起動するので、そのままfsck -fyすると最後まで行ったが、control + d でシングルユーザモードを抜けると同じ現象発生
この辺でお手上げと判断して、Appleの修理を受け付けているクイックガレージに持って行った。
有線LANから起動する診断ツールを使っていろいろなテストをしてもらったが、原因の特定まで行かず。
疑わしいのは、非純正のDRAMか、メイン基板で、純正のメモリが残っていたら刺し直せばもう少し特定できるかもとのこと。
メイン基板の交換の場合は55,000円+税になり、5日くらいかかると言うので、そのまま返してもらい隣の販売店へ。
2013年秋モデルのMacBook Pro Retina 15インチを、現在と同じスペック(メモリ16G、SSD512G)で購入した。
うちに帰ると、早速箱を開けて、TimeCapsuleにあるTimeMachineバックアップから移行・・・と思ったらうまくいかない。
移行ウィザードにTimeCapsuleは認識されるけど、選択すると「バックアップにボリュームがありません」とか言って先に進めない。
10.9 Mavericksインストール時TimeMachineから移行できない。 | Apple サポートコミュニティみたいな記事を見つけたけど、どうも少し違う現象のようで、そもそもTimeCapsule上にあるsparsebundleをマウントしようとすると、エラーが出て成功しない。(メッセージ忘れちゃった)
この間に、古いmbpのメモリを1枚ずつ抜いて見たりしたが症状は改善せず。いよいよメイン基板っぽい。
せっかく開けたので、SSDを取り出してUSBで新しいmbpに接続。
中身は普通に読めたので、TimeMachineからの復旧は諦めてUSB HDDを指定しての移行ウィザード。
やっぱり何もコピーされない・・・。なんで?
もう移行ウィザードは捨てて、rsyncでホームディレクトリをコピー。
後は、App Storeのアプリを再インストールしたり、flash playerやJava VMを入れたりしながらクリーン環境からの復旧を進めていく。
以前は日本語入力はGoogle日本語入力を使っていたのだけれど、せっかくクリーンな環境になったのだからと言うことでATOKの試用版を入れてみたら、一発で動いた。(以前は、ATOKを入れるとレインボーカーソルで何もできない状態になった)
さらに、ATOK Passportはベーシックと言う選択肢ができ、月額286円+税らしいので、1ヶ月使ってみて課金するか決めようと思う。

この後、だいたい環境が整ったら、TimeCapsuleは一度ディスクを初期化し、再度TimeMachineの設定をしてフルバックアップ。
しかし、いざってときに使えないバックアップは意味がないよなあ。

カテゴリ

トラックバック(0)

このブログ記事を参照しているブログ一覧: MacBook Proも逝く

このブログ記事に対するトラックバックURL: http://www.wizard-limit.net/cgi-bin/mt/mt-tb.cgi/3157

コメントする

このブログ記事について

このページは、falseが2014年5月11日 05:47に書いたブログ記事です。

ひとつ前のブログ記事は「NASのバックアップをFreeBSDで」です。

次のブログ記事は「Raspberry pi」です。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。

広告

Powered by Movable Type 5.2.10